Como adoptar un pingüino

BLOG de AZULcasiNEGRO, donde se cuentan básicamente las peripecias durante la migración a Kubuntu/Linux

Aviso Cookies

Categories

Contador

Eres el visitante

Hace un par de días que actualicé mi máquina de trabajo a Intrepid. Sí, he tardado. Pero es que es la del trabajo, y hasta que las de casa han demostrado ser estable con KDE4 no quería arriesgarme.
Bueno, continuo. Esta mañana al arrancar, he verificado que todo funcionara sin problemas. Hasta aquí todo correcto. Pero usándolo me doy cuenta que faltan un par de cosillas: Información climatológica y una barra de lanzamiendo rápido con múltiples filas. Buscando en KDE-Look veo las dos soluciones, que ahora os contaré como instalar.

Antes de empezar con los plasmoids (se llaman así estos añadidos de KDE4), tenemos que instalar algunas cosillas para poder generar los binarios.

sudo aptitude install cmake build-essential kdelibs5-dev libplasma-dev kdebase-workspace-dev
gettext
En el paso anterior es donde está el "truco". Luego os cuento el porqué.

Instalando Yet Another Weather Plasmoid


Descargamos de la web de yaWP el código fuente. Y seguimos los pasos que describe la instalación general.
tar -xvf nombre_paquete.tar.gz
cd nombre_carpeta_donde_se_descomprimió
mkdir build
cd build
cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix` ..
make
sudo make install

Con esto ya os tendría que salir en la lista de componentes instalables. Después de configurarlo, el resultado es este :

Chulo, no ? Hay otro en los repositorios, pero sólo da la temperatura y gracias.
Aunque parece una chorrada, a las personas que he instalado Kubuntu les ha parecido interesante tener esta información. Y migrar de KDE 3.5 a KDE 4 sin poder igualar o mejorar este detalle es la diferencia entre el éxito y el fracaso para un usuario de a pie.

Instalando QuickLauncher Applet


El proceso es similar al anterior.
tar -xvf nombre_paquete.tar.gz
cd nombre_carpeta_donde_se_descomprimió
mkdir build
cd build
cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix` ../src
make
sudo make install

Fijaros que cuando llamamos a cmake la carpeta que indicamos es ../src y no ..
Y el resultado es este:

Comentaros que podeis añadir nuevas aplicaciones arrastrando desde el menú, o buscando en /usr/share/applications y sus carpetas.

Como arreglar un fallo de compilación


Resulta que lo que os he descrito como paso previo no te lo cuentan. Y es que pueden salir errores de este tipo.
$ make
[ 25%] Generating ui_quicklauncherAdd.h
Generating quicklauncher.moc
[ 25%] Generating ui_quicklauncherConfig.h
[ 25%] Building CXX object CMakeFiles/plasma_applet_quicklauncher.dir/plasma_applet_quicklauncher_automoc.o
[ 25%] Building CXX object CMakeFiles/plasma_applet_quicklauncher.dir/quicklauncher.o
/home/users/xavier/Plasmoids/plasma-applet-quicklauncher-0.5/src/quicklauncher.cpp:26:35:
error: kworkspace/kworkspace.h: No existe el fichero ó directorio
make[2]: *** [CMakeFiles/plasma_applet_quicklauncher.dir/quicklauncher.o] Error 1
make[1]: *** [CMakeFiles/plasma_applet_quicklauncher.dir/all] Error 2
make: *** [all] Error 2

¿ Qué ha pasado ? Pues que no encuentra kworkspace.h
¿ De donde lo sacamos ? Bueno, lo primero es localizar el paquete que lo incluye. Para eso necesitamos instalar apt-file.
Una vez lo tenemos instalado, actualizamos el listado interno de búsqueda mediante
$ sudo apt-file update

No os preocupeis si tarda un ratito. Es normal. Lo que hace es crear un listado con todos los archivos de todos los paquetes(.deb) de todos los repositorios que tenemos configurados.
Ahora ya podemos pedirle que busque dónde está.
$ apt-file find kworkspace.h
kdebase-workspace-dev: /usr/include/kworkspace/kworkspace.h

Nos contesta que esta kdebase-workspace-dev. Pues lo instalamos y veremos que ya no da este error.

2 comentarios

  1. phonon440  

    Hola, muy bueno el desarrollo, te cuento que en una instalación desde cero de kubuntu intrepid me fue necesario instalar el paquete gettext para que se pudiera generar el fichero sin error.
    saludos

  2. AZULcasiNEGRO  

    phonon440 tienes razón.
    Lo que pasa es que cuando escribí el manualillo sólo habia la versión 0.0.6, que no necesita gettext.
    Ahora lo añado para tenerlo actualizado.

Publicar un comentario

Cuenta atrás

Nuestros derechos

Recent Posts

Recent Comments